Electrical – Switching Mode Power Supply Fluctuating Output

dcpower supplyswitch-mode-power-supplyswitchingtesting

I designed a switching mode power supply using LNK-562, I share the circuit schematic below.

https://i.imgur.com/q7GMugS.png

Note that NTC, fuse, and the input filter inductor is replaced with shorts in the real circuits.

I am testing the circuit in varying conditions and I noticed that the circuit fails to keep the output voltage the same for every condition. For example, if I use 100 Ohms as the load, the output is 3V. For the case of an output load of 220 Ohms, I get 5V (which is the intended voltage). Eventually, the voltage converges to 8V with no load condition. The circuit should be able to handle an output power of 1.5W. So, I understand that the circuit will fail to keep the voltage at 5V in the no load case, however, a small variation of changing the resistor to 220 to 100 should not change the output figures that much. Given the power requirement, I should be able to connect a 20 Ohm resistor.

I tested every node of the circuit. Bias circuit seems to be working fine. The LNK562 operates by keeping the voltage at TP1 constant. Namely, it should be 1.69V for all cases of loads and this is verified by an oscilloscope measurement.

Note that the fluctuations in the output voltage are kept at minimum. For the case of 5V output, the ripple is measured to be 12mV which is a very good figure considering that this is a student project and by no means it is designed for commercial market.

What do you suggest I do? Which nodes I should check and what kind of waveform might be an indication of a problem? How do you define the problem I have?

The circuit is now being tested at 110V RMS. Also, I am a senior EEE student. Also note that the circuit is printed and verified by the professor.

Best Answer

The regulation of that configuration can be poor, as it depends on a tight coupling between N2 and N3 and how closely does the voltage on C3 follows the voltage of the changing load. Given the 36k & 1uF load on that feedback circuit it is likely to be too slow to respond to load changes, and too sensitive to initial transients on the transformer coils.

You can try by reducing the 33k resistor and/or 1uF capacitor. And/or adding a load directly to N3 to reduce the influence of the switching transients.