Php – Can’t install Imagick for PHP on Debian from source, error says requires 6.2.4 when I have 6.7.7 installed


Pulling my hair out. PHP built from source, everything working. Now need to install imagick and can't get it installed.

I am running Debian on kernel 3.7.1 with PHP 5.3.20 (the last version my app supports, cannot go to PHP 5.4).

pecl install imagick
checking ImageMagick MagickWand API configuration program... found in /usr/bin/Wand-config
checking if ImageMagick version is at least 6.2.4... configure: error: no. You need at least Imagemagick version 6.2.4 to use Imagick.
ERROR: `/tmp/pear/temp/imagick/configure --with-imagick' failed

Yet, I have version 6.7.7 installed:

# convert --version
Version: ImageMagick 6.7.7-10 2012-11-06 Q16
Copyright: Copyright (C) 1999-2012 ImageMagick Studio LLC
Features: OpenMP

I also tried installing the latest beta (pecl install imagick-beta), same result. Also tried an old version 2.3.0, same result. Also tried downloading source, phpize, and configure — same result.

Best Answer

I was finally able to solve this myself. I ended up doing:

apt-get remove graphicsmagick-libmagick-dev-compat imagemagick imagemagick-common
apt-get autoremove


apt-get install libmagickwand-dev

And finally was able to get imagick installed via pecl without error:

pecl install imagick-beta