Cisco OSPF – Configuring OSPF with Multi-Areas

ciscoospfpacket-tracerrouterrouting

I'm trying to recreate a theoretical situation in packet tracer with 3 areas with the protocol OSPF for some reason there's no communication between the devices, even when the ospf hop can see the other devices.

R1

interface FastEthernet0/0
 ip address 192.168.0.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 10.0.0.1 255.255.255.0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 network 192.168.0.0 0.0.0.255 area 1
 network 10.0.0.0 0.0.0.3 area 1
!

R2

interface FastEthernet0/0
 ip address 11.0.0.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 10.0.0.2 255.255.255.0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
 area 2 virtual-link 3.3.3.3
 network 10.0.0.0 0.0.0.3 area 1
 network 11.0.0.0 0.0.0.3 area 2
!

R3

interface FastEthernet0/0
 ip address 11.0.0.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 12.0.0.1 255.255.255.0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 1
 router-id 3.3.3.3
 log-adjacency-changes
 area 2 virtual-link 2.2.2.2
 network 11.0.0.0 0.0.0.255 area 2
 network 12.0.0.0 0.0.0.3 area 3
!

R4

interface FastEthernet0/0
 ip address 192.168.1.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 12.0.0.2 255.255.255.0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 1
 router-id 4.4.4.4
 log-adjacency-changes
 network 12.0.0.0 0.0.0.3 area 3
 network 192.168.1.0 0.0.0.255 area 3
!

Network

Best Answer

Areas 1 and 3 can't directly communicate with Area 2. OSPF areas can only connect to to Area 0. If you change Area 2 to Area 0, things should work much better. Also, you can't have discontiguous Area 0s.