VLAN Routing – Routing VLAN Out to Internet on a Cisco 3750G

ciscofirewallroutingswitchvlan

I have a WAN port (firewall, 192.168.70.1/24) plugged into port 24 of a Cisco 3750G.

interface GigabitEthernet1/0/24
  no switchport
  ip address 192.168.70.2 255.255.255.0

I have my default route going out this port.

ip route 0.0.0.0 0.0.0.0 192.168.70.1

I can get out to the internet from the switch.

I have a computer (192.168.71.201/24 GW .1) plugged into port 1, vlan 71:

interface GigabitEthernet1/0/1
  switchport access vlan 71
  switchport mode access

interface Vlan71
  ip address 192.168.71.1 255.255.255.0

The computer can ping the 71.1 gateway, however can't get to the internet via 70.1.

How do I route this out?


Full Switch Config:

version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname pac-inet-cs1
!
boot-start-marker
boot-end-marker
!
enable secret 5 xxx
enable password xxx
!
!
!
no aaa new-model
switch 1 provision ws-c3750g-24t
system mtu routing 1500
authentication mac-move permit
ip subnet-zero
ip routing
ip name-server 8.8.8.8
ip name-server 4.4.4.4
!
crypto pki trustpoint TP-self-signed-231101568
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-231101568
 revocation-check none
 rsakeypair TP-self-signed-231101568
!
!
crypto pki certificate chain TP-self-signed-231101568
 certificate self-signed 01
 xxx
!
!
!
spanning-tree mode pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
interface GigabitEthernet1/0/1
 switchport access vlan 71
 switchport mode access
!
interface GigabitEthernet1/0/2
 switchport access vlan 71
 switchport mode access
!
interface GigabitEthernet1/0/3
!
interface GigabitEthernet1/0/4
!
interface GigabitEthernet1/0/5
!
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
!
interface GigabitEthernet1/0/13
!
interface GigabitEthernet1/0/14
!
interface GigabitEthernet1/0/15
!
interface GigabitEthernet1/0/16
!
interface GigabitEthernet1/0/17
!
interface GigabitEthernet1/0/18
!
interface GigabitEthernet1/0/19
!
interface GigabitEthernet1/0/20
!
interface GigabitEthernet1/0/21
!
interface GigabitEthernet1/0/22
!
interface GigabitEthernet1/0/23
!
interface GigabitEthernet1/0/24
 no switchport
 ip address 192.168.70.2 255.255.255.0
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan71
 description Spectrum Public
 ip address 192.168.71.1 255.255.255.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.70.1
ip http server
ip http secure-server
!
!
ip sla enable reaction-alerts
!
!
!
line con 0
line vty 0 4
 password xxx
 login
line vty 5 15
 password xxx
 login
!
end

Best Answer

One likely problem is that you have not enabled routing on the switch. This is very common. You need to make sure that you enable routing from the global configuration mode:

ip routing

Also, your firewall needs to know to send traffic destined to the 192.168.71.0/24 network to the switch. Unless you have a static route in the firewall or you are running a common routing protocol between the firewall and the switch, the firewall has no way to know to send that traffic to the switch, so it will send the traffic to its default route (the Internet connection).