EIGRP – Redistribution Between EIGRP and Static Routing Protocols

eigrpredistribution

I have configured EIGRP and STATIC protocols between two areas and both protocols at Area border router. unfortunately I'm unable to ping between two areas, the networks are configured correctly and the communication between networks within an area taking place easily,

I have written the following commands as taught me

router eigrp 99
redistribute static metric 10000 10 255 100 1000

and

ip route 0.0.0.0 255.255.255.255 124.29.242.38

and yes the via route 124.29.242.38 in static is correct and up.

Edit

enter image description here

The highlighted top most router is the area boundary router with EIGRP at right and STATIC at its left

and the sh running-configuration

Router#sh running-config 
Building configuration...

.
.
!
interface Serial0/0/0
 ip address 124.29.242.37 255.255.255.252
 clock rate 64000
!
interface Serial0/0/1
 ip address 180.92.128.193 255.255.255.252
 clock rate 64000
!
interface Serial0/1/0
 ip address 124.29.242.33 255.255.255.252
 clock rate 64000
!
interface Serial0/1/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 99
 redistribute static metric 10000 10 255 100 1000 
 network 180.92.0.0
 network 124.0.0.0
 no auto-summary
!
ip classless
ip route 124.29.242.40 255.255.255.248 124.29.242.38 
ip route 124.29.242.48 255.255.255.252 124.29.242.38 
ip route 124.29.242.52 255.255.255.252 124.29.242.38 
ip route 124.29.242.56 255.255.255.252 124.29.242.38 
ip route 192.168.10.0 255.255.255.0 124.29.242.38 
ip route 192.168.20.0 255.255.255.0 124.29.242.38 
ip route 192.168.30.0 255.255.255.0 124.29.242.38 
ip route 0.0.0.0 0.0.0.0 124.29.242.38 
!
.
.
!
end

sh running-configuration for left router STATIC

Router#sh running-config 
Building configuration...

.
.
interface FastEthernet0/0
 ip address 124.29.242.41 255.255.255.248
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 ip address 124.29.242.38 255.255.255.252
 clock rate 2000000
!
interface Serial0/0/1
 ip address 124.29.242.49 255.255.255.252
 clock rate 64000
!
interface Serial0/1/0
 ip address 124.29.242.53 255.255.255.252
 clock rate 64000
!
interface Serial0/1/1
 ip address 124.29.242.57 255.255.255.252
 clock rate 64000
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 192.168.10.0 255.255.255.0 124.29.242.50 
ip route 192.168.20.0 255.255.255.0 124.29.242.54 
ip route 192.168.30.0 255.255.255.0 124.29.242.58 
!
.
.
!
end

sh running-configuration for right router EIGRP

Router#sh running-config 
Building configuration...

.
.
!
interface FastEthernet0/0
 ip address 180.92.128.201 255.255.255.248
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/1/0
 ip address 180.92.128.194 255.255.255.252
 clock rate 2000000
!
interface Serial0/1/1
 ip address 180.92.128.198 255.255.255.252
 clock rate 2000000
!
interface Serial0/2/0
 ip address 180.92.128.209 255.255.255.252
 clock rate 64000
!
interface Serial0/2/1
 ip address 180.92.128.213 255.255.255.252
 clock rate 64000
!
interface Serial0/3/0
 ip address 180.92.128.217 255.255.255.252
 clock rate 64000
!
interface Serial0/3/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 99
 network 180.92.0.0
 no auto-summary
!
ip classless
!
.
.
!
end

Best Answer

It is hard to tell from your description and lack of sh run from the other two routers, but I believe this portion of the configuration is the problem:

ip route 0.0.0.0 255.255.255.255 124.29.242.38

This should be a default route statement. Currently it is routing packets with the destination IP address of 0.0.0.0 only instead of acting as a default route. To do so you will have to replace it or add the following static route:

ip route 0.0.0.0 0.0.0.0 124.29.242.38

You can test your routing paths with show ip route $interfaceip on both sides to confirm this route selection.