Routing – Cisco Nexus 5k EIGRP Configuration

cisco-nexus-5kcisco-nx-oseigrprouterrouting

I have two Cisco Nexus switches with EIGRP Routers.

Switch 1:

SWITCH1(config-if)# sh run

!Command: show running-config
!Time: Sun Feb 21 05:29:57 2016

version 5.0(3)U5(1f)
no feature telnet
no telnet server enable
feature eigrp
feature interface-vlan
feature hsrp
feature lacp
feature dhcp
feature vtp

username admin password 5 ####################################  role network-admin
no password strength-check
ip domain-lookup
hostname ALS-CORE-NX1
ipv6 access-list copp-system-acl-dhcpc6
  10 permit udp any any eq 546
ipv6 access-list copp-system-acl-dhcps6
  10 permit udp any ff02::0001:0002/128 eq 547
  20 permit udp any ff05::0001:0003/128 eq 547
ip access-list copp-system-acl-eigrp
  10 permit eigrp any 224.0.0.10/32
ipv6 access-list copp-system-acl-eigrp6
  10 permit 88 any ff02::000a/128
ip access-list copp-system-acl-icmp
  10 permit icmp any any
ip access-list copp-system-acl-igmp
  10 permit igmp any any
ip access-list copp-system-acl-ntp
  10 permit udp any any eq ntp
  20 permit udp any eq ntp any
ip access-list copp-system-acl-pimreg
  10 permit pim any any
ip access-list copp-system-acl-ping
  10 permit icmp any any echo
  20 permit icmp any any echo-reply
ip access-list copp-system-acl-routingproto1
  10 permit tcp any gt 1024 any eq bgp
  20 permit tcp any eq bgp any gt 1024
  30 permit udp any 224.0.0.0/24 eq rip
  40 permit tcp any gt 1024 any eq 639
  50 permit tcp any eq 639 any gt 1024
  70 permit ospf any any
  80 permit ospf any 224.0.0.5/32
  90 permit ospf any 224.0.0.6/32
ip access-list copp-system-acl-routingproto2
  10 permit udp any 224.0.0.0/24 eq 1985
  20 permit 112 any 224.0.0.0/24
ip access-list copp-system-acl-snmp
  10 permit udp any any eq snmp
  20 permit udp any any eq snmptrap
ip access-list copp-system-acl-ssh
  10 permit tcp any any eq 22
  20 permit tcp any eq 22 any
ip access-list copp-system-acl-stftp
  10 permit udp any any eq tftp
  20 permit udp any any eq 1758
  30 permit udp any eq tftp any
  40 permit udp any eq 1758 any
  50 permit tcp any any eq 115
  60 permit tcp any eq 115 any
ip access-list copp-system-acl-tacacsradius
  10 permit tcp any any eq tacacs
  20 permit tcp any eq tacacs any
  30 permit udp any any eq 1812
  40 permit udp any any eq 1813
  50 permit udp any any eq 1645
  60 permit udp any any eq 1646
  70 permit udp any eq 1812 any
  80 permit udp any eq 1813 any
  90 permit udp any eq 1645 any
  100 permit udp any eq 1646 any
ip access-list copp-system-acl-telnet
  10 permit tcp any any eq telnet
  20 permit tcp any any eq 107
  30 permit tcp any eq telnet any
  40 permit tcp any eq 107 any
ipv6 access-list copp-system-acl-v6routingProto2
  10 permit udp any ff02::0066/128 eq 2029
  20 permit udp any ff02::00fb/128 eq 5353
ipv6 access-list copp-system-acl-v6routingproto1
  10 permit 89 any ff02::0005/128
  20 permit 89 any ff02::0006/128
  30 permit udp any ff02::0009/128 eq 521
ip access-list copp-system-dhcp-relay
  10 permit udp any eq bootps any eq bootps
ip access-list customer-acl
  10 permit ip 10.0.23.0/24 any
  20 deny ip 10.0.0.0/8 any
  30 permit ip any any
class-map type qos class-fcoe
class-map type queuing class-fcoe
  match qos-group 1
class-map type queuing class-all-flood
  match qos-group 2
class-map type queuing class-ip-multicast
  match qos-group 2
class-map type network-qos class-fcoe
  match qos-group 1
class-map type network-qos class-all-flood
  match qos-group 2
class-map type network-qos class-ip-multicast
  match qos-group 2
class-map type control-plane match-any copp-icmp
  match access-group name copp-system-acl-icmp
class-map type control-plane match-any copp-ntp
  match access-group name copp-system-acl-ntp
class-map type control-plane match-any copp-s-arp
class-map type control-plane match-any copp-s-bfd
class-map type control-plane match-any copp-s-bpdu
class-map type control-plane match-any copp-s-dai
class-map type control-plane match-any copp-s-default
class-map type control-plane match-any copp-s-dhcpreq
  match access-group name copp-system-acl-dhcps6
class-map type control-plane match-any copp-s-dhcpresp
  match access-group name copp-system-acl-dhcpc6
  match access-group name copp-system-dhcp-relay
class-map type control-plane match-any copp-s-eigrp
  match access-group name copp-system-acl-eigrp
  match access-group name copp-system-acl-eigrp6
class-map type control-plane match-any copp-s-glean
class-map type control-plane match-any copp-s-igmp
  match access-group name copp-system-acl-igmp
class-map type control-plane match-any copp-s-ipmcmiss
class-map type control-plane match-any copp-s-l2switched
class-map type control-plane match-any copp-s-l3destmiss
class-map type control-plane match-any copp-s-l3mtufail
class-map type control-plane match-any copp-s-l3slowpath
class-map type control-plane match-any copp-s-pimautorp
class-map type control-plane match-any copp-s-pimreg
  match access-group name copp-system-acl-pimreg
class-map type control-plane match-any copp-s-ping
  match access-group name copp-system-acl-ping
class-map type control-plane match-any copp-s-ptp
class-map type control-plane match-any copp-s-routingProto1
  match access-group name copp-system-acl-routingproto1
  match access-group name copp-system-acl-v6routingproto1
class-map type control-plane match-any copp-s-routingProto2
  match access-group name copp-system-acl-routingproto2
class-map type control-plane match-any copp-s-selfIp
class-map type control-plane match-any copp-s-ttl1
class-map type control-plane match-any copp-s-v6routingProto2
  match access-group name copp-system-acl-v6routingProto2
class-map type control-plane match-any copp-snmp
  match access-group name copp-system-acl-snmp
class-map type control-plane match-any copp-ssh
  match access-group name copp-system-acl-ssh
class-map type control-plane match-any copp-stftp
  match access-group name copp-system-acl-stftp
class-map type control-plane match-any copp-tacacsradius
  match access-group name copp-system-acl-tacacsradius
class-map type control-plane match-any copp-telnet
  match access-group name copp-system-acl-telnet
policy-map type control-plane copp-system-policy 
  class copp-s-selfIp
    police pps 500 
  class copp-s-default
    police pps 400 
  class copp-s-l2switched
    police pps 200 
  class copp-s-ping
    police pps 100 
  class copp-s-l3destmiss
    police pps 100 
  class copp-s-glean
    police pps 500 
  class copp-s-l3mtufail
    police pps 100 
  class copp-s-ttl1
    police pps 100 
  class copp-s-ipmcmiss
    police pps 400 
  class copp-s-l3slowpath
    police pps 100 
  class copp-s-dhcpreq
    police pps 300 
  class copp-s-dhcpresp
    police pps 300 
  class copp-s-dai
    police pps 300 
  class copp-s-igmp
    police pps 400 
  class copp-s-eigrp
    police pps 200 
  class copp-s-pimreg
    police pps 200 
  class copp-s-pimautorp
    police pps 200 
  class copp-s-routingProto2
    police pps 4000 
  class copp-s-v6routingProto2
    police pps 1600 
  class copp-s-routingProto1
    police pps 4000 
  class copp-s-arp
    police pps 200 
  class copp-s-ptp
    police pps 1000 
  class copp-s-bfd
    police pps 350 
  class copp-s-bpdu
    police pps 6000 
  class copp-icmp
    police pps 200 
  class copp-telnet
    police pps 500 
  class copp-ssh
    police pps 500 
  class copp-snmp
    police pps 500 
  class copp-ntp
    police pps 100 
  class copp-tacacsradius
    police pps 400 
  class copp-stftp
    police pps 400 
control-plane
  service-policy input copp-system-policy 
vtp mode transparent
vtp domain BASEVTP
hardware profile portmode 64x10G
snmp-server user admin network-admin auth md5 ################################# priv ################################# localizedkey
ntp server 10.1.3.20 use-vrf management

vrf context management
  ip route 0.0.0.0/0 10.1.2.1 1
vlan 1-3
vlan 4
vlan 5
vlan 6
vlan 7
vlan 8
vlan 10
vlan 23
vlan 24
vlan 25
vlan 28
vlan 40
vlan 41
vlan 42
vlan 43
vlan 44
vlan 45
vlan 46
vlan 47
vlan 48
vlan 49
vlan 50
vlan 51
vlan 53
vlan 54
vlan 60
vlan 61-64
vlan 100
vlan 101
vlan 200
vlan 256-257
service dhcp
ip dhcp relay


interface Vlan1
  ip address 10.0.1.3/24
  no shutdown
  bandwidth 500

interface Vlan2
  ip address 10.1.2.2/24
  no shutdown
  bandwidth 500

interface Vlan4
  ip address 10.1.4.2/24
  hsrp 7 
    timers  1  3
    ip 10.1.4.1 
  no shutdown

interface Ethernet1/1
  switchport access vlan 2
  speed 1000

interface Ethernet1/2
  no switchport
  ip address 172.16.1.1/24
  ip router eigrp CORE

interface Ethernet1/3

interface Ethernet1/4

interface Ethernet1/5

interface Ethernet1/6

interface Ethernet1/7

interface Ethernet1/8

interface Ethernet1/9

interface Ethernet1/10

interface Ethernet1/11
  switchport mode trunk

interface Ethernet1/12

interface Ethernet1/13

interface Ethernet1/14

interface Ethernet1/15

interface Ethernet1/16

interface Ethernet1/17

interface Ethernet1/18

interface Ethernet1/19

interface Ethernet1/20

interface Ethernet1/21

interface Ethernet1/22

interface Ethernet1/23

interface Ethernet1/24

interface Ethernet1/25

interface Ethernet1/26

interface Ethernet1/27

interface Ethernet1/28

interface Ethernet1/29
  switchport access vlan 7

interface Ethernet1/30

interface Ethernet1/31

interface Ethernet1/32

interface Ethernet1/33

interface Ethernet1/34

interface Ethernet1/35

interface Ethernet1/36

interface Ethernet1/37

interface Ethernet1/38

interface Ethernet1/39

interface Ethernet1/40

interface Ethernet1/41

interface Ethernet1/42

interface Ethernet1/43

interface Ethernet1/44

interface Ethernet1/45

interface Ethernet1/46

interface Ethernet1/47

interface Ethernet1/48

interface Ethernet1/49/1

interface Ethernet1/49/2

interface Ethernet1/49/3

interface Ethernet1/49/4

interface Ethernet1/50/1

interface Ethernet1/50/2

interface Ethernet1/50/3

interface Ethernet1/50/4

interface Ethernet1/51/1

interface Ethernet1/51/2

interface Ethernet1/51/3

interface Ethernet1/51/4

interface Ethernet1/52/1

interface Ethernet1/52/2

interface Ethernet1/52/3

interface Ethernet1/52/4

interface mgmt0
  ip address 10.1.2.30/24
line console
line vty
boot kickstart bootflash:/n3000-uk9-kickstart.5.0.3.U5.1f.bin 
boot system bootflash:/n3000-uk9.5.0.3.U5.1f.bin 
router eigrp CORE
  address-family ipv4 unicast
    autonomous-system 3
    redistribute direct route-map default
ip eigrp event-history errors
ip eigrp event-history cli size small

Switch 2:

SWITCH2# sh run

!Command: show running-config
!Time: Sun Feb 21 05:32:01 2016

version 5.1(3)N2(1)
hostname SWITCH2#

no feature telnet
feature eigrp
feature interface-vlan
feature hsrp
feature lacp
feature dhcp
feature lldp
feature vtp

username admin password 5 ####################################  role network-admin
ip domain-lookup
ip access-list customer-acl
  10 permit ip 10.0.23.0/24 any
  20 deny ip 10.0.0.0/8 any
  30 permit ip any any
class-map type qos class-fcoe
class-map type queuing class-fcoe
  match qos-group 1
class-map type queuing class-all-flood
  match qos-group 2
class-map type queuing class-ip-multicast
  match qos-group 2
class-map type network-qos class-fcoe
  match qos-group 1
class-map type network-qos class-all-flood
  match qos-group 2
class-map type network-qos class-ip-multicast
  match qos-group 2
snmp-server user admin network-admin auth md5 #################################### priv #################################### localizedkey
ntp server 10.1.3.20 use-vrf management

vrf context management
  ip route 0.0.0.0/0 10.1.2.1 1
  ip route 0.0.0.0/0 10.1.5.1
vlan configuration 8
route-map COREMAP permit 10
service dhcp
ip dhcp relay


interface Vlan1
  no shutdown
  bandwidth 500
  ip address 10.0.1.1/24

interface Vlan2
  no shutdown
  ip address 10.1.2.1/24

interface Vlan3
  no shutdown
  ip address 10.1.3.3/24
  hsrp 7 
    timers  1  3
    ip 10.1.3.1 

interface Vlan4
  no shutdown
  ip address 10.1.4.3/24
  hsrp 7 
    timers  1  3
    ip 10.1.4.1 

interface Vlan5
  no shutdown
  ip address 10.1.5.3/24
  hsrp 5 
    timers  1  3
    ip 10.1.5.1 
  ip dhcp relay address 10.0.23.11 

interface Vlan6
  no shutdown
  ip address 10.1.6.3/24
  hsrp 6 
    timers  1  3
    ip 10.1.6.1 

interface Vlan7
  no shutdown
  ip address 10.1.7.3/24
  hsrp 1 
    timers  1  3
    ip 10.1.7.1 

interface Vlan8
  no shutdown
  ip address 10.1.8.1/24
  ip arp 10.1.8.50 03BF.0A01.0832

interface Vlan9
  no shutdown
  ip address 10.0.9.3/24
  hsrp 7 
    timers  1  3
    ip 10.0.9.1 

interface Vlan10
  no shutdown
  ip address 10.0.10.3/24
  hsrp 7 
    timers  1  3
    ip 10.0.10.1 

interface Vlan20
  no shutdown
  ip address 10.0.20.3/24
  hsrp 7 
    timers  1  3
    ip 10.0.20.1 

interface Vlan21
  no shutdown
  ip address 10.0.21.3/24
  hsrp 7 
    timers  1  3
    ip 10.0.21.1 

interface Vlan22
  no shutdown
  ip address 10.0.22.3/24
  hsrp 7 
    timers  1  3
    ip 10.0.22.1 

interface Vlan23
  no shutdown
  ip address 10.0.23.3/24
  hsrp 7 
    timers  1  3
    ip 10.0.23.1 

interface Vlan24
  no shutdown
  ip address 10.0.24.3/24
  hsrp 7 
    timers  1  3
    ip 10.0.24.1 

interface Vlan25
  no shutdown
  ip address 10.0.25.3/24
  hsrp 7 
    preempt 
    timers  1  3
    ip 10.0.25.1 

interface Vlan26
  no shutdown
  ip address 10.0.26.3/24
  hsrp 7 
    timers  1  3
    ip 10.0.26.1 

interface Vlan27
  no shutdown
  ip address 10.0.27.3/24
  hsrp 7 
    timers  1  3
    ip 10.0.27.1 

interface Vlan28
  no shutdown
  ip address 10.0.28.3/24
  hsrp 1 
    timers  1  3
    ip 10.0.28.1 

interface Vlan40
  no shutdown
  ip address 10.0.40.3/24
  hsrp 7 
    timers  1  3
    ip 10.0.40.1 

interface Vlan41
  no shutdown
  ip address 10.0.41.3/24
  hsrp 7 
    timers  1  3
    ip 10.0.41.1 

interface Vlan42
  no shutdown
  ip address 10.0.42.3/24
  hsrp 7 
    timers  1  3
    ip 10.0.42.1 

interface Vlan43
  no shutdown
  ip address 10.0.43.3/24
  hsrp 7 
    timers  1  3
    ip 10.0.43.1 

interface Vlan44
  no shutdown
  ip address 10.0.44.3/24
  hsrp 7 
    timers  1  3
    ip 10.0.44.1 

interface Vlan45
  no shutdown
  ip address 10.0.45.3/24
  hsrp 7 
    timers  1  3
    ip 10.0.45.1 

interface Vlan46
  no shutdown
  ip address 10.0.46.3/24
  hsrp 7 
    timers  1  3
    ip 10.0.46.1 

interface Vlan47
  no shutdown
  ip address 10.0.47.3/24
  hsrp 7 
    timers  1  3
    ip 10.0.47.1 

interface Vlan48
  no shutdown
  ip address 10.0.48.3/24
  hsrp 7 
    timers  1  3
    ip 10.0.48.1 

interface Vlan49
  no shutdown
  ip address 10.0.49.3/24
  hsrp 7 
    timers  1  3
    ip 10.0.49.1 

interface Vlan50
  no shutdown
  ip address 10.0.50.3/24
  hsrp 7 
    timers  1  3
    ip 10.0.50.1 

interface Vlan53
  no shutdown
  ip access-group customer-acl out
  ip address 10.0.53.3/24
  hsrp 7 
    timers  1  3
    ip 10.0.53.1 

interface Vlan54
  no shutdown
  ip address 10.0.54.3/24
  hsrp 7 
    timers  1  3
    ip 10.0.54.1 

interface Vlan60
  no shutdown
  ip access-group customer-acl out
  ip address 10.0.60.3/24
  hsrp 1 
    ip 10.0.60.1 

interface Vlan61
  no shutdown
  ip access-group customer-acl out
  ip address 10.0.61.3/24
  hsrp 1 
    ip 10.0.61.1 

interface Vlan62
  no shutdown
  ip access-group customer-acl out
  ip address 10.0.62.3/24
  hsrp 1 
    ip 10.0.62.1 

interface Vlan63
  no shutdown
  ip access-group customer-acl out
  ip address 10.0.63.3/24
  hsrp 1 
    ip 10.0.63.1 

interface Vlan64
  no shutdown
  ip access-group customer-acl out
  ip address 10.0.64.3/24
  hsrp 1 
    timers  1  3
    ip 10.0.64.1 

interface Vlan100
  no shutdown
  ip address 10.0.100.3/24
  hsrp 7 
    timers  1  3
    ip 10.0.100.1 

interface Vlan101
  no shutdown
  ip address 10.0.101.3/24
  hsrp 7 
    timers  1  3
    ip 10.0.101.1 

interface Vlan311
  no shutdown
  ip address 10.3.11.3/24
  hsrp 7 
    timers  1  3
    ip 10.3.11.1 

interface port-channel1
  switchport access vlan 7
  speed 10000

interface port-channel2
  switchport access vlan 7
  speed 10000

interface port-channel3
  switchport access vlan 7
  speed 10000

interface port-channel4
  switchport access vlan 7
  speed 10000

interface port-channel5
  switchport access vlan 7
  speed 10000

interface Ethernet1/1
  switchport access vlan 2
  speed 1000

interface Ethernet1/2
  no switchport
  ip address 172.16.1.2/24
  ip router eigrp CORE

interface Ethernet1/3

interface Ethernet1/4

interface Ethernet1/5

interface Ethernet1/6

interface Ethernet1/7

interface Ethernet1/8

interface Ethernet1/9
  switchport mode trunk

interface Ethernet1/10
  switchport mode trunk

interface Ethernet1/11
  switchport mode trunk

interface Ethernet1/12
  switchport mode trunk

interface Ethernet1/13
  switchport mode trunk

interface Ethernet1/14
  switchport mode trunk

interface Ethernet1/15
  switchport access vlan 7
  channel-group 4 mode active

interface Ethernet1/16
  switchport access vlan 7
  channel-group 4 mode active

interface Ethernet1/17
  switchport access vlan 7
  channel-group 5 mode active

interface Ethernet1/18
  switchport access vlan 7
  channel-group 5 mode active

interface Ethernet1/19

interface Ethernet1/20

interface Ethernet1/21
  switchport access vlan 2
  speed 1000

interface Ethernet1/22

interface Ethernet1/23

interface Ethernet1/24

interface Ethernet1/25

interface Ethernet1/26

interface Ethernet1/27
  switchport access vlan 7
  channel-group 2 mode active

interface Ethernet1/28
  switchport access vlan 7
  channel-group 2 mode active

interface Ethernet1/29
  switchport access vlan 7
  channel-group 1 mode active

interface Ethernet1/30
  switchport access vlan 7
  channel-group 1 mode active

interface Ethernet1/31
  switchport mode trunk
  speed 1000

interface Ethernet1/32
  switchport mode trunk
  speed 1000

interface mgmt0
  ip address 10.1.2.15/24
line console
line vty
boot kickstart bootflash:/n5000-uk9-kickstart.5.1.3.N2.1.bin
boot system bootflash:/n5000-uk9.5.1.3.N2.1.bin 
router eigrp CORE
  address-family ipv4 unicast
    autonomous-system 3
    redistribute direct route-map default
    redistribute static route-map default
ip route 0.0.0.0/0 10.1.2.3

Part of logs (truncated for question length limit):

2016 Feb 21 03:53:40.741490 eigrp: CORE [9196] (default-base)  DUAL: Removing dest 10.0.1.0/24, nexthop 172.16.1.1
2016 Feb 21 03:53:40.741506 eigrp: CORE [9196] (default-base) ipigrp2_urib_rtuninstall: 10.0.1.0/24 via 172.16.1.1 not in urib, not sent to urib, del pending 
2016 Feb 21 03:53:40.741520 eigrp: CORE [9196] (default-base)    Found serno 10
2016 Feb 21 03:53:40.741533 eigrp: CORE [9196] (default-base) ipigrp2_rtdelete L1963: 10.1.2.0/24 via 172.16.1.1
2016 Feb 21 03:53:40.741547 eigrp: CORE [9196] (default-base) ipigrp2_urib_rtuninstall: 10.1.2.0/24 via 172.16.1.1 not in urib, not sent to urib, del pending 
2016 Feb 21 03:53:40.741563 eigrp: CORE [9196] (default-base)  DUAL: Removing dest 10.1.2.0/24, nexthop 172.16.1.1
2016 Feb 21 03:53:40.741578 eigrp: CORE [9196] (default-base) ipigrp2_urib_rtuninstall: 10.1.2.0/24 via 172.16.1.1 not in urib, not sent to urib, del pending 

In the end, it looks like EIGRP doesn't like something and removes the incoming route advertisements, and my google-fu has not yielded anything that points me in the right direction.
I have yet to configure any authentication, to make the setup simple for the moment.

Thanks

Best Answer

I could be wrong here, but it looks to me like both switches have the same subnets defined. If I'm DUAL I'm going to remove a route I learn from you if I already have that subnet locally connected.