OSPF Configuration – Why Doesn’t It Work?

ospfrouting

I have a network on Packet tracer consisting of 3 routers and 1 ISP router. Each router is connected to a switch. I am practising using OSPF v2 for my Cisco CCNA tests.
I have configured Router 1:

interface Serial0/0/0
 ip address 192.168.28.202 255.255.255.252
 clock rate 2000000
!
interface Serial0/0/1
 ip address 192.168.28.209 255.255.255.252
 clock rate 2000000
!
router ospf 1
 log-adjacency-changes
 network 192.168.28.200 0.0.0.3 area 0
 network 192.168.28.208 0.0.0.3 area 0
!

router 2:

interface Serial0/0/0
 ip address 192.158.28.206 255.255.255.252
 clock rate 2000000
!
interface Serial0/0/1
 ip address 192.168.28.210 255.255.255.252
 clock rate 2000000
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes
 network 192.168.28.204 0.0.0.3 area 0
 network 192.168.28.208 0.0.0.3 area 0
!

and router 3:

interface Serial0/0/0
 ip address 192.168.28.201 255.255.255.252
 clock rate 2000000
!
interface Serial0/0/1
 ip address 192.168.28.205 255.255.255.252
 clock rate 2000000
!
interface Serial0/1/0
 ip address 123.123.123.31 255.255.255.0
 clock rate 2000000
!
router ospf 1
 log-adjacency-changes
 network 192.168.28.200 0.0.0.3 area 0
 network 192.168.28.204 0.0.0.3 area 0
!
ip default-gateway 123.123.123.31

Using this set up I currently have Router 1 and Router 3 exchanging, Router 1 and router 2 as well but Router 2 and Router 3 just don't work. I have removed all the network entries and started again.
But they just don't seem to want to play.
Just for clarity here is the OSPF neighbours table for router 1:

Neighbor ID     Pri   State           Dead Time   Address         Interface
202.202.29.254    0   FULL/  -        00:00:35    192.168.28.201  Serial0/0/0
192.168.28.210    0   FULL/  -        00:00:38    192.168.28.210  Serial0/0/1

router 2:

Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.28.209    0   FULL/  -        00:00:30    192.168.28.209  Serial0/0/1

router 3:

Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.28.209    0   FULL/  -        00:00:32    192.168.28.202  Serial0/0/0

Any ideas why OSPF isn't working for the final connection?

Thanks

Best Answer

There is a typo on router 2, the IP address of serial0/0/0 is incorrect:

ip address 192.158.28.206 255.255.255.252

158 instead of 168...