Vlan – How to configure DHCP pools for 2 VLANs/subnets sharing a switch

cisco-commandscisco-iosdhcppacket-tracervlan

I've set up DHCP pools on a layer 3 switch that goes out to 13 layer 2 switches. Most of which have their own subnet and VLANs, and everything works fine when that's the case. But when there are two VLANs/subnets sharing a switch, the hosts on that VLAN or subnet can't seem to get their IP address assigned by the DHCP server, and instead have link-local addresses. What am I probably doing wrong?

I'm using Cisco Catalyst switches. I've also been trying to figure it out with Packet Tracer, but no having much luck.

Here are the details of the vlans and subnets:


enter image description here


Below are some of the configs. Including the main L3 switch, and some of the switches that are having problems.


Multilayer Switch

L3CORE#show run
Building configuration...

Current configuration : 5687 bytes
!
version 12.2(37)SE1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname L3CORE
!
!
!
ip dhcp excluded-address 10.0.0.1
ip dhcp excluded-address 10.0.2.1
ip dhcp excluded-address 10.0.2.65
ip dhcp excluded-address 10.0.2.129
ip dhcp excluded-address 10.0.2.161
ip dhcp excluded-address 10.0.2.193
ip dhcp excluded-address 10.0.2.225
ip dhcp excluded-address 10.0.3.1
ip dhcp excluded-address 10.0.3.33
ip dhcp excluded-address 10.0.3.65
ip dhcp excluded-address 10.0.3.81
ip dhcp excluded-address 10.0.3.97
ip dhcp excluded-address 10.0.3.113
ip dhcp excluded-address 10.0.3.121
!
ip dhcp pool 425
 network 10.0.0.0 255.255.254.0
ip dhcp pool 325
 network 10.0.2.0 255.255.255.192
 default-router 10.0.0.1
ip dhcp pool 350
 network 10.0.3.80 255.255.255.240
 default-router 10.0.0.1
ip dhcp pool vlan350
 network 10.0.3.80 255.255.255.240
 default-router 10.0.3.81
ip dhcp pool 150
 network 10.0.2.192 255.255.255.224
 default-router 10.0.0.1
ip dhcp pool range
ip dhcp pool vlan425
 network 10.0.0.0 255.255.254.0
ip dhcp pool vlan325
 network 10.0.2.0 255.255.255.192
 default-router 10.0.2.1
ip dhcp pool vlan225
 network 10.0.2.64 255.255.255.192
 default-router 10.0.2.65
ip dhcp pool vlan375
 network 10.0.2.128 255.255.255.224
 default-router 10.0.2.129
ip dhcp pool vlan300
 network 10.0.2.160 255.255.255.224
 default-router 10.0.2.161
ip dhcp pool vlan150
 network 10.0.2.192 255.255.255.224
 default-router 10.0.2.193
ip dhcp pool vlan250
 network 10.0.2.224 255.255.255.224
 default-router 10.0.2.225
ip dhcp pool vlan275
 network 10.0.3.0 255.255.255.224
 default-router 10.0.3.1
ip dhcp pool vlan125
 network 10.0.3.32 255.255.255.224
 default-router 10.0.3.33
ip dhcp pool vlan200
 network 10.0.3.64 255.255.255.240
 default-router 10.0.3.65
ip dhcp pool vlan175
 network 10.0.3.96 255.255.255.240
 default-router 10.0.3.97
ip dhcp pool vlan400
 network 10.0.3.120 255.255.255.252
 default-router 10.0.3.121
ip dhcp pool vlan100
 network 10.0.3.112 255.255.255.248
 default-router 10.0.3.113
!
!
ip routing
!
!
!
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/1
 switchport trunk allowed vlan 100,350,375,400,425
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/2
 switchport trunk allowed vlan 325,425
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/3
 switchport trunk allowed vlan 225,275,425
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/4
 switchport trunk allowed vlan 150,425
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/5
 switchport trunk allowed vlan 175,425
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/6
 switchport trunk allowed vlan 250,425
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/7
 switchport trunk allowed vlan 425
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/8
 switchport trunk allowed vlan 375,425
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/9
 switchport trunk allowed vlan 425
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/10
 switchport trunk allowed vlan 425
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/11
 switchport trunk allowed vlan 325,425
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/12
 switchport trunk allowed vlan 300,425
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/13
 switchport trunk allowed vlan 200,425
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/14
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan100
 mac-address 00e0.8f6d.4301
 ip address 10.0.3.113 255.255.255.248
!
interface Vlan125
 mac-address 00e0.8f6d.4302
 ip address 10.0.3.33 255.255.255.224
!
interface Vlan150
 mac-address 00e0.8f6d.4303
 ip address 10.0.2.193 255.255.255.224
!
interface Vlan175
 mac-address 00e0.8f6d.4304
 ip address 10.0.3.97 255.255.255.240
!
interface Vlan200
 mac-address 00e0.8f6d.4305
 ip address 10.0.3.65 255.255.255.240
!
interface Vlan225
 mac-address 00e0.8f6d.4306
 ip address 10.0.2.65 255.255.255.192
!
interface Vlan250
 mac-address 00e0.8f6d.4307
 ip address 10.0.2.225 255.255.255.224
!
interface Vlan275
 mac-address 00e0.8f6d.4308
 ip address 10.0.3.1 255.255.255.224
!
interface Vlan300
 mac-address 00e0.8f6d.4309
 ip address 10.0.2.161 255.255.255.224
!
interface Vlan325
 mac-address 00e0.8f6d.430a
 ip address 10.0.2.1 255.255.255.192
!
interface Vlan350
 mac-address 00e0.8f6d.430b
 ip address 10.0.3.81 255.255.255.240
!
interface Vlan375
 mac-address 00e0.8f6d.430c
 ip address 10.0.2.129 255.255.255.224
!
interface Vlan400
 mac-address 00e0.8f6d.430d
 ip address 10.0.3.121 255.255.255.252
!
interface Vlan425
 mac-address 00e0.8f6d.430e
 ip address 10.0.0.1 255.255.254.0
!
router rip
 network 10.0.0.0
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
!
end

Switch 03

S03#show run
Building configuration...

Current configuration : 2485 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname S03
!
!
!
clock timezone awst 8
!
no ip domain-lookup
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
 switchport access vlan 275
 switchport mode access
!
interface FastEthernet0/2
 switchport access vlan 275
 switchport mode access
!
interface FastEthernet0/3
 switchport access vlan 275
 switchport mode access
!
interface FastEthernet0/4
 switchport access vlan 275
 switchport mode access
!
interface FastEthernet0/5
 switchport access vlan 275
 switchport mode access
!
interface FastEthernet0/6
 switchport access vlan 275
 switchport mode access
!
interface FastEthernet0/7
 switchport access vlan 275
 switchport mode access
!
interface FastEthernet0/8
 switchport access vlan 275
 switchport mode access
!
interface FastEthernet0/9
 switchport access vlan 275
 switchport mode access
!
interface FastEthernet0/10
 switchport access vlan 275
 switchport mode access
!
interface FastEthernet0/11
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/12
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/13
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/14
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/15
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/16
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/17
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/18
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/19
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/20
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/21
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/22
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/23
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/24
 switchport access vlan 225
 switchport mode access
!
interface GigabitEthernet0/1
 switchport trunk allowed vlan 225,275,425
 switchport mode trunk
!
interface GigabitEthernet0/2
 switchport access vlan 425
 switchport mode access
!
interface Vlan1
 no ip address
 shutdown
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
!
end

Switch 07

S07#show run
Building configuration...

Current configuration : 2511 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname S07
!
!
!
clock timezone awst 8
!
no ip domain-lookup
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/2
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/3
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/4
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/5
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/6
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/7
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/8
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/9
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/10
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/11
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/12
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/13
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/14
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/15
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/16
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/17
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/18
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/19
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/20
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/21
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/22
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/23
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/24
 switchport access vlan 225
 switchport mode access
!
interface GigabitEthernet0/1
 switchport trunk allowed vlan 225,425
 switchport mode trunk
!
interface GigabitEthernet0/2
 switchport access vlan 425
 switchport mode access
!
interface Vlan1
 no ip address
 shutdown
!
ip default-gateway 10.0.0.1
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
!
end

Switch 08

S08#show run

Building configuration...

Current configuration : 2582 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname S08
!
!
ip dhcp excluded-address 10.0.2.65
!
clock timezone awst 8
!
no ip domain-lookup
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/2
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/3
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/4
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/5
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/6
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/7
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/8
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/9
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/10
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/11
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/12
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/13
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/14
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/15
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/16
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/17
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/18
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/19
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/20
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/21
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/22
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/23
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/24
 switchport access vlan 225
 switchport mode access
!
interface GigabitEthernet0/1
 switchport trunk allowed vlan 225,425
 switchport mode trunk
!
interface GigabitEthernet0/2
 switchport access vlan 425
 switchport mode access
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan225
 mac-address 0007.ec6d.3c01
 no ip address
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
!
end

Switch 09

S09#show run
Building configuration...

Current configuration : 2481 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname S09
!
!
!
clock timezone awst 8
!
no ip domain-lookup
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/2
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/3
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/4
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/5
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/6
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/7
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/8
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/9
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/10
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/11
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/12
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/13
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/14
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/15
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/16
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/17
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/18
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/19
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/20
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/21
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/22
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/23
 switchport access vlan 225
 switchport mode access
!
interface FastEthernet0/24
 switchport access vlan 225
 switchport mode access
!
interface GigabitEthernet0/1
 switchport trunk allowed vlan 225,425
 switchport mode trunk
!
interface GigabitEthernet0/2
 switchport access vlan 425
 switchport mode access
!
interface Vlan1
 no ip address
 shutdown
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
!
end

enter image description here

Best Answer

I think one big problem is that you have not defined the VLANs on the access switches. Yes, you have the SVIs for the VLANs, but you didn't globally define the VLANs.

For example:

Vlan 225
 name Production
exit
!
Vlan 275
 name Finance
exit
!

Forgetting to do that will often cause problems like you describe. Add that to all the DHCP server problems you have on the layer-3 switch, and you have a real mess.

See this question for the same problem, and the answer was to define the VLANs.