Cisco 887VA router ADSL configuration

adslciscorouter

I am attempting to setup a Cisco 887VA to connect out to the internet via a basic ADSL connection.
I have configured it to the best of my ability but its the first one I've ever done and I think I may have overlooked something silly. I have triple checked everything and all but the ADSL username/password being incorrect, I cannot see what else it could be.

Could anyone take a look over my config and see if anything stands out please?

Using 3473 out of 262136 bytes
!
! Last configuration change at 08:22:49 UTC Tue May 24 2016 by administrator
!
version 15.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
no service timestamps debug uptime
no service timestamps log uptime
service password-encryption
no service dhcp
!
hostname rtr-h003103
!
boot-start-marker
boot system tftp c880data-universalk9-mz.154-3.M5.bin 255.255.255.255
boot system flash:c880data-universalk9-mz.154-3.M5.bin
boot-end-marker
!
!
no logging buffered
no logging console
!
aaa new-model
!
!
aaa authentication login default local
aaa authentication enable default enable
aaa authentication ppp default local
aaa authorization exec default local
!
!
!
!
!
aaa session-id common
memory-size iomem 10
!
crypto pki trustpoint TP-self-signed-1297352779
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-1297352779
 revocation-check none
 rsakeypair TP-self-signed-1297352779
!
!
crypto pki certificate chain TP-self-signed-1297352779
 certificate self-signed 01 nvram:IOS-Self-Sig#1.cer
!
!
!
!
!
!
!
!
!
!
!
!
!
ip domain name mydomain.local
ip cef
no ipv6 cef
!
!
cts logging verbose
license udi pid CISCO887VA-K9 sn FCZ1524C3GC
!
!
archive
 log config
  hidekeys
username administrator privilege 15 secret 5 $1$vd2f$WpvhuZd3aufh0bd0SPUhQ/
username ccpuser privilege 15 secret 5 $1$vqGL$stHJZv4odwJC5LOCvhVpr.
!
!
!
!
!
controller VDSL 0
no cdp run
!
!
!
!
!
!
!
!
!
!
!
interface Ethernet0
 description ADSL LAN Interface
 ip address 192.168.2.100 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat inside
 ip virtual-reassembly in
!
interface ATM0
 no ip address
 shutdown
 no atm ilmi-keepalive
 pvc 0/38
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
!
interface FastEthernet0
 no ip address
!
interface FastEthernet1
 no ip address
!
interface FastEthernet2
 no ip address
!
interface FastEthernet3
 no ip address
!
interface Vlan1
 description 192.168.1.0 LAN (Connected to CCTV Feed)
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
interface Dialer0
 description Test (ADSL)
 ip address 81.136.61.19 255.255.255.254
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip flow ingress
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp authentication chap pap callin
 ppp chap hostname user@hg70.btclick.com
 ppp chap password 7 07072055420C0002051D1E1C55
 ppp pap sent-username user@hg70.btclick.com password 7 030C5A120A0A384B5C060C1546
 ppp ipcp dns request
 ppp ipcp route default
 no cdp enable
!
interface Dialer1
 no ip address
 no cdp enable
!
ip forward-protocol nd
no ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip ftp username root
ip ftp password 7 0201545F06090B240D
ip nat inside source list 10 interface Dialer0 overload
ip nat inside source list natin interface Dialer0 overload
ip nat inside source static 192.168.1.250 81.149.241.71
ip route 0.0.0.0 0.0.0.0 Dialer0
ip ssh version 1
ip ssh pubkey-chain
  username administrator
!
ip access-list standard natin
 permit 192.168.1.0 0.0.0.255
!
dialer-list 1 protocol ip permit
!
access-list 10 permit 192.168.2.0 0.0.0.255
!
!
!
!
line con 0
 privilege level 15
 no modem enable
line aux 0
line vty 0 4
 privilege level 15
 transport input telnet ssh
line vty 5 15
 exec-timeout 0 0
 privilege level 15
 transport input none
!
!
end

Thank you in advance.

Best Answer

Don't worry, I have found the solution! Looks like adding the following worked for me:

interface ATM0
 description --- Internode ADSL ---
 no ip address
 no atm ilmi-keepalive
 no shutdown
 pvc 8/35 
  tx-ring-limit 3
  encapsulation aal5snap
  pppoe-client dial-pool-number 1

I am now able to ping out from the router. Sorted! Thank you.