Cisco – Rate Limit VLAN interface | Cisco Nexus

ciscocisco-nexusqosrate-limiting

How to do QoS in cisco nexus for Rate limit.
In cisco Routers , we will be creating a policy map and calling it in service_policy in VLAN Interface

Ex:

Policy-map Policy_2Mbps
  class class-default
    police cir 2048000 bc 384000 be 384000 conform-action transmit exceed-action drop violate-action drop


interface Vlan10
 description *** DEMO ***
 ip address x.x.x.x s.s.s.s
 shutdown
 standby 62 ip x.x.x.y
 standby 62 priority 110
 standby 62 preempt
 service-policy input Policy_2Mbps
 service-policy output Policy_2Mbps 

How can we achieve the same in CISCO NEXUS.
Whole idea is to bandwidth limit for VLAN interface

Best Answer

Nexus platform does not support all the QoS features for it being a datacenter switch and therefore you could only limit traffic inbound to that port but outbound traffic policing is not really supported. This should limit traffic in one side at least.

So you should try something like:

ip access-list limit-acl
  10 permit ip any any
!
class-map type qos match-all limit-qos-cmap
  match access-group name limit-acl
!
policy-map type qos limit-qos-pmap
  class limit-qos-cmap
    set qos-group 2
    police cir 2 mbps bc 250 ms
!
interface  [...]
service-policy type qos input limit-qos-pmap
!