Cisco router configuration for pppoe dhcp and nat

ciscoconfiguration

I am trying to set up a cisco 2800 series router in my home lab. yes its old, but cheap enough to play around with.

So I am coming up against a problem configuring the router.

I can ping out to the internet from the router directly. so its making a pppoe connection just fine.

I can ping the router from a connected pc which is getting assigned its appropriately assigned ip details. I cant however get an internet connection on that router, pinging googles dns server fails and pages wont load.

I am sure i have missed something but have no clue as to what that might be.

Here are the steps taken to set the configs. fa0/0 connects to a modem, fa0/1 connects to a computer (will be a switch)

conf t

int fa0/0

no shut

pppoe enable group global

pppoe-client dial-pool-number 1

exit

int dialer 1

no shut

ip address negotiated

encapsulation ppp

ip tcp adjust-mss 1442

dialer pool 1
dialer-group 1

ppp authentication chap callin

ppp chap hostname *******

ppp chap password *******

exit

ip route 0.0.0.0 0.0.0.0 dialer 1

exit

conf t

int fa0/1

ip address 10.0.2.1 255.255.255.0

no shut

exit

service dhcp

ip dhcp pool lan1

network 10.0.2.0 255.255.255.0

default-router 10.0.2.1

dns-server 8.8.8.8 8.8.4.4

lease 1

exit

ip dhcp excluded-address 10.0.2.1 10.0.2.25

int fa0/1
ip nat inside

exit

int dialer 1

ip nat outside

exit

ip nat inside source list 1 interface dialer 1 overload

exit

Best Answer

I finally got this sorted.

I am sure there are settings that are not strictly required, though I'm finally able to get my cisco router to provide internet internet to the servers so that's a start. Next is securing and port forwarding but I will update here as I build my configuration up.

conf t

int dialer 1
 ip address negotiated
 ip mtu 1492
 ip nat outside
 encapsulation ppp
 ip tcp adjust-mss 1452
 dialer pool 10
 dialer-group 1
 ppp authentication chap callin
 ppp chap hostname ************
 ppp chap password ************
 ppp ipcp route default
 ppp ipcp dns request
 ppp ipcp address accept
 exit

vpdn enable
vpdn-group 1
  request-dialin
  exit
 exit

int fa0/1
 no shut
 pppoe enable group global
 pppoe-client dial-pool-number 10
 exit

int fa0/0
 ip address 10.0.2.1 255.255.255.0
 no shut
 ip nat inside
 no cdp enable
 no mop enabled
 exit

conf t

ip dhcp excluded-address 10.0.2.1 10.0.2.25
ip dhcp excluded-address 192.168.1.253 192.168.1.254

ip dhcp pool Homepool
 network 10.0.2.0 255.255.255.0
 dns-server 8.8.8.8 8.8.4.4
 domain-name local.lan
 default-router 10.0.2.1
 exit

conf t
ip nat inside source list 10 interface dialer 1

access-list 10 permit 10.0.2.0 0.0.0.255

no cdp run

int fa0/0
 description Lan Side

int fa0/1
 description ISP Side