How to forward network packages to an interface in Mikrotik

mikrotikrouterostcpudp

I want to forward all TCP packets to one interface (a dedicated Internet connection only for downloads) and all UDP packets to another one (a dedicated internet connection only for streaming and videogames). How can I do that? My router is the Mikrotik RB750.

Best Answer

If you want to split the incoming network traffic between two local connections, assuming each of your interfaces have a different address, you could do it with dst-nat:

/ip firewall nat
add in-interface=[incoming interface] action=dst-nat protocol=tcp dst-address=[TCP address]
add in-interface=[incoming interface] action=dst-nat protocol=udp dst-address=[UDP address]

In case what you meant was to split the outgoing traffic between two outside connections, and each of the connections have a different address, you could do it this way:

/ip firewall nat
add chain=srcnat protocol=tcp action=src-nat to-address=[TCP connection address] out-interface=[TCP interface]
add chain=srcnat protocol=udp action=src-nat to-address=[UDP connection address] out-interface=[UDP interface]