Lvm – VGDA full in a scalable volume group? (extendvg)

aixlvm

I have an AIX 6.1 volume group called arscachevg. It is a few terabytes big and consists of 15 physical volumes. When I try to extend it with a new physical volume, I get this error:

0516-008 extendvg: LVM system call returned an unknown
    error code (-267).
0516-050 extendvg: Not enough descriptor area space left in this volume
    group. Either try adding a smaller PV or use another volume group.
0516-792 extendvg: Unable to extend volume group.

I always thought that scalable VGs had no practical limitations!

Some info from lsvg on the volume group:

PP SIZE:            256 megabyte(s)
MAX PVs:            1024
TOTAL PPs:          13185 (3375360 megabytes)
FREE PPs:           570 (145920 megabytes)
USED PPs:           12615 (3229440 megabytes)
QUORUM:             8 (Enabled)
MAX LVs:            256
LVs:                11
OPEN LVs:           11
TOTAL PVs:          15
ACTIVE PVs:         15
MAX PPs per VG:     262144
LTG size (Dynamic): 256 kilobyte(s)

Anyone that can explain why this fails? The new disk is 350 GB.

I even tried chvg -t2 arscachevg, but it is not a valid command on a scalable VG:

0516-1781 chvg: The t option is not valid for volume groups of the Scalable Volume Group type.
0516-732 chvg: Unable to change volume group arscachevg.

Very grateful if there are any AIX-LVM gurus out there that can shed some light on this.
Thanks!

Best Answer

Answering my own question...

First some more info:

Creating a new "plain" volume group with only this disk worked:

# mkvg -y cachevg -f -S hdisk20
cachevg

Creating a new scalable or big volume group with this disk, with tweaked parameters failed in the same way as when trying to extend the original scalable volume group.

# mkvg -y cachevg -f -S -s 1024 hdisk20
0516-008 mkvg: LVM system call returned an unknown
    error code (-267).
0516-1395 mkvg: The physical volume hdisk20, is not supported.
0516-862 mkvg: Unable to create volume group.

Weird, huh?

What was the problem, then?

As it turns out, the 350 GB LUN I got was somehow, for some reason (maybe it contained data previously?), discovered by AIX as being a mere 175 MB:

# getconf DISK_SIZE /dev/hdisk20
175

What I did to remedy this was to force AIX to "rediscover" the LUN again. First I dd:ed /dev/zero for a while onto /dev/hdisk20, then forgot about the disk with rmdev.

It was not sufficient with just rmdev -l hdisk20. That left it as Defined in the ODM, so instead I did:

rmdev -Rdl hdisk20

and then rediscovered it with cfgmgr, and voilá:

# getconf DISK_SIZE /dev/hdisk20
358400

From there on, it was business as usual. I assigned a new PVID just for comfort, and then I extended the original scalable volume group without any problems whatsoever.

Sensmoral

Don't take AIX LVM error messages literally. It hinted about adding a smaller PV, when in fact the PV I used was too small! I assume it was too small to even fit the VGDA.